Thunar, mplayer et les thumb­nails

Ceux qui me connaissent savent que je ne jure que par Xfce en ce qui concerne l’en­vi­ron­ne­ment de bureau : il est rapide, bien plus léger que Kde, ne demande pas une tripo­tée de dépen­dances comme Gnome et est bien plus convi­vial que les envi­ron­ne­ments tels que Wmii.

Le gestion­naire de fichiers d’Xfce est Thunar, auquel je ne trouve qu’un défaut : les minia­tures des vidéos. Celles-ci sont gérées par ffmpeg-thumb­nai­ler et c’est parfois pas terrible. Quand je l’uti­li­sais, ralen­tis­se­ments et plan­tages étaient quoti­diens. Si bien que j’avais renoncé aux minia­tures de mes vidéos.

Derniè­re­ment, je me suis dit que si Kde utili­sait mplayer pour ses minia­tures, pourquoi ne pour­rais-je pas le faire avec Xfce (enfin Thunar).

Et la réponse est vite arri­vée : oui, on le peut !

Sous Debian, c’est très simple (avec les autres distri­bu­tions, ce doit être simple aussi mais je ne sais pas si les fichiers sont au même endroit) :

Vous créez un fichier video-thumbs.desk­top (enfin vous pompez celui que je mets ici), vous le mettez dans /usr/share/thumb­nai­lers/ et un petit coup de chmod 755 par dessus, ce sera parfait.

Un autre fichier, mplayer-thumb­nai­ler, dans /usr/lib/thunar-thumb­nai­lers/ et c’est tout !

Et j’ai fait tout ça grâce à cette page : http://wiki.zenwalk.org/index.php?title=Enable_video_thumb­nails_in_thunar

J’ai un peu modi­fié le script de créa­tion de l’image parce que ça ne marchait pas bien sur des vidéos mal indexées (chez moi, toutes les vidéos en .mov prove­nant d’un appa­reil photo) et main­te­nant c’est nickel. Par contre je n’ai pas réussi à lui faire faire les minia­tures de vidéos en Ogg. Si quelqu’un a une idée, je suis preneur.

Me soutenir sur Tipeee Me soutenir sur Liberapay

2 réflexions au sujet de « Thunar, mplayer et les thumb­nails »

  1. Les deux premières adresses envoient sur Fiat Tux, avec le messsage : Rien de trouvé.
    La dernière ne mène nulle part : Not found.

    1. J’avais écrit ce billet sur mon ancien blog et les liens n’ont pas été actualisés.
      Le premier lien est maintenant bon, je n’ai plus le fichier du second et le troisième, ben c’est pas chez moi, donc je ne peux rien faire.

      Ceci dit, c’était pour la version d’XFCE de l’époque, il y a trois ans, je pense qu’il vaut mieux tenter de trouver une doc plus à jour… Désolé.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *