Archives du mot-clé Wheezy

La mise à jour Debian, l’ipv6 et les conte­neurs lxc

Suite à la mise à jour vers Debian Wheezy, je me suis rendu compte grâce à un ami en full IPv6 que je n’avais plus IPv6 sur mes conte­neurs !

C’est simple et assez embê­tant. J’avais mis mes routes IPv6 dans le /etc/rc.local des conte­neurs (voir pourquoi dans ce billet) et il semble que ce fichier n’ait pas été joué lors du redé­mar­rage :(

Il m’a suffit de jouer les instruc­tions qui étaient dedans pour que ça remarche. Il faudra que je regarde pourquoi ça n’a pas marché et comment régler le problème.

Bref, faites gaffe et véri­fiez que vous contac­tez bien vos conte­neurs en IPv6 depuis l’ex­té­rieur (ou tentez de contac­ter un serveur en IPv6 depuis un de vos conte­neurs).

Me soutenir sur Tipeee Me soutenir sur Liberapay

When it’s ready…

Debian Wheezy est sortie le 4 mai 2013, en bon debia­neux fana­tique, je ne pouvais que me dépê­cher de mettre à jour :D

Si mes machines de travail sous sid/expe­ri­men­tal (oui, oui, même celle du boulot) n’en ont pas eu besoin, mon brave petit serveur OVH (non, ce n’est pas de la pub, je suis juste content de leur boulot) lui, est passé à la mouli­nette.

Après avoir lu en entier les recom­man­da­tions kivon­bien, je me suis lancé dans la grande aven­tu­re… qui était fina­le­ment bien courte !

L’up­grade de mes contai­ners s’est passé(e?) comme un charme, pas plus compliqué(e?) qu’un apt-get dist-upgrade.

Pour le dom0, j’ai par contre eu une petite frayeur : les contai­ners se sont arrê­tés lors de la procé­dure de mise à jour (jusque là, ça semble normal) mais ils n’ont pas voulu redé­mar­rer !  (ouille) Mais alors vrai­ment pas, avec messages d’injures en anglais et tout et tout.

Après 3 secondes de recherches sur le web, il semblait que c’était à cause d’un noyau trop ancien pour la nouvelle version des outils lxc. Soit. Upgrade de noyau, reboot… et rien !

Panique, sueurs froides, apéro (si, si, j’ai une vie sociale ! J’ai juste eu la mauvaise idée de faire l’up­grade du dom0 avant d’al­ler boire un coup), pings néga­tifs pendant l’apéro, retour… et ouf ! Juste une vache­rie de fsck (fallait s’y attendre) qui a fait que le reboot a pris un looooong moment. Ovh avait détecté que mon serveur était éteint et avait envoyé un tech­ni­cien sur place, ils m’ont ensuite informé que tout allait bien et qu’il y avait eu un fsck. Ça m’a rassuré pour le coup, entre deux coups de rosé.

Plus qu’à relan­cer les contai­ners à la main (je sais pas pourquoi ils n’ont pas redé­marré auto­ma­tique­ment, à voir demain) et revoilà mon serveur en ligne.

Conclu­sion : la vie est belle et les mecs de chez Debian font un vache de bon boulot. Merci !

PS : c’est juste dommage d’avoir perdu un uptime de 281 jours. Bah ! D’ici Jessy, j’au­rais bien 2 ans d’up­time si tout va bien :D

PPS : non, c’est pas parce que je suis un admin en carton que je me casse boire un pot en plein reboot d’après mise à jour. C’est juste que j’ai ÉNORMÉMENT confiance en Debian…  que j’avais soif et que je ne m’ap­pelle pas Google : un down­time de 4/5h sur un an, c’est pas trop grave quand même. ;)

Me soutenir sur Tipeee Me soutenir sur Liberapay