Archives pour la catégorie Tuto

Migra­tion d’une version majeure de Post­greSQL à une autre (pour Debian Stretch)

Aver­tis­se­ment Ceci est une réac­tua­li­sa­tion d’un précé­dent article. J’en avais marre de devoir chan­ger les numé­ros de version dans mes copier/coller (quoi, vous ne croyez quand même pas que je me souviens de ces commandes par cœur ?), donc je réac­tua­lise l’ar­ticle, ce sera plus confor­table pour tout le monde.

Avec la sortie de Stretch, c’est Post­greSQL 9.6 qui est proposé. Mais comment faire pour migrer les bases de données du clus­ter 9.4 (qui ne rece­vra plus trop d’up­dates) vers le 9.6 ? Ce n’est pas très compliqué.

On stoppe les clus­ters Post­greSQL

service postgresql stop

On vire le clus­ter de la nouvelle version (norma­le­ment vide si on vient juste de l’ins­tal­ler : faire gaffe à ne pas lais­ser passer de temps entre l’ins­tal­la­tion de la nouvelle version et la migra­tion des données, pour que personne n’uti­lise le nouveau clus­ter)

pg_dropcluster --stop 9.6 main

On migre les données

pg_upgradecluster -m upgrade 9.4 main

On restoppe l’an­cien clus­ter (il a démarré tout seul pour la migra­tion)

service postgresql stop 9.4

On teste les applis qui utilisent Post­greSQL Si ça fonc­tionne, on vire les anciennes données

pg_dropcluster 9.4 main

On vire l’an­cienne version de Post­greSQL

apt-get autoremove --purge postgresql-9.4

C’est plutôt simple, n’est-ce pas ?

Source

Me soutenir sur Tipeee Me soutenir sur Liberapay

Utili­ser un Turris Omnia comme client VPN

J’ai récem­ment acheté un routeur Turris Omnia. En effet, ayant démé­nagé dans un appar­te­ment dispo­sant de la fibre, je ne pouvais plus avoir de liai­son ADSL chez LDN. Qu’à celà ne tienne me disais-je, je prends un VPN chez eux et hop, j’ai un accès tout propre à Inter­net. Mais mon fidèle Buffalo était trop peu puis­sant pour faire office de client VPN pour une bande passante aussi élevée. D’où le Turris, plus puis­sant (et on peut faire plein de trucs avec, c’est un très beau jouet (certes, pas donné)).

Voici comment je m’y suis pris. Tout d’abord, envoyer sur le Turris les fichiers néces­saires à la connexion VPN four­nis par LDN : ca_server.crt, client.crt, et client.key. Je mets tout ça dans /etc/openvpn.

Puis je rajoute la confi­gu­ra­tion VPN au fichier /etc/config/openvpn :

config openvpn 'vpn'
    option enabled '1'
    option client '1'
    option dev 'tun'
    option keepalive '10 1200'
    option nobind '1'
    option ca '/etc/openvpn/ca_server.crt'
    option cert '/etc/openvpn/client.crt'
    option key '/etc/openvpn/client.key'
    option ns_cert_type 'server'
    option comp_lzo 'yes'
    option verb '3'
    option log '/tmp/log/openvpn.log'
    list remote 'vpn.ldn-fai.net 1194'
    option up '/etc/openvpn/up.sh'
    option down '/etc/openvpn/down.sh'
    option script_security '2'

Dans le script /etc/openvpn/up.sh, je remplace les routes par défaut du routeur pour faire passer tout le trafic par le VPN, et dans /etc/openvpn/down.sh, je les remets en place. Je crois (j’ai fait toutes ces mani­pu­la­tions il y a quelques mois, je ne me souviens plus très bien) que j’ai créé ces scripts parce que les routes ne se mettaient pas en place toutes seules.

NB : le réseau de la box opéra­teur est 192.168.2.0/24, je l’ai modi­fié pour ne pas le confondre avec mon réseau local 192.168.1.0/24 fourni par le Turris. 192.168.2.1 est l’adresse IP de la box.

/etc/openvpn/up.sh :

#!/bin/ash
ip route del default via 192.168.2.1 dev eth1
ip route add default via mon_IP_publique_fournie_par_LDN dev tun0
exit 0

/etc/openvpn/down.sh :

#!/bin/ash
ip route del default via mon_IP_publique_fournie_par_LDN dev tun0
ip route add default via 192.168.2.1 dev eth1
exit 0

Pour que le routeur arrive quand même à joindre le serveur VPN de LDN une fois les routes par défaut modi­fiées, j’ai modi­fié le fichier /etc/config/network :

config route
    option interface 'wan'
    option target '80.67.188.131' # IP du serveur vpn.ldn-fai.net
    option metric '10'
    option gateway '192.168.2.1'

config route
    option interface 'vpn'
    option target '0.0.0.0'
    option netmask '0.0.0.0'
    option gateway 'mon_IP_publique_fournie_par_LDN'

Au niveau du fire­wall, il faut créer une zone tun et ajou­ter quelque petits trucs (dans /etc/config/firewall) :

config zone
    option input 'ACCEPT'
    option output 'ACCEPT'
    option name 'tun'
    option masq '1'
    option network 'vpn'
    option forward 'REJECT'

config forwarding
    option dest 'wan'
    option src 'lan'

config forwarding
    option dest 'wan'
    option src 'tun'

config forwarding
    option dest 'tun'
    option src 'lan'

Norma­le­ment, il y a tout ce qu’il faut pour faire du Turris (et par exten­sion, d’un routeur sous OpenWRT) un client VPN qui va four­nir un réseau exploi­tant ce VPN.

Et l’IPv6 ? C’est vrai, je n’ai pas parlé d’IPv6 ici. Tout d’abord parce qu’il m’a moins embêté qu’IPv4 (pas besoin de redé­fi­nir les routes par défaut dans des scripts par exemple), ensuite parce que j’ai des bouts de confi­gu­ra­tion IPv6 dont je ne pas convaincu qu’ils soient néces­saires. Je vous les donne quand même :

Dans /etc/config/network :

config route6
    option interface 'wan'
    option target '2001:913:0:2000::131'  # IP du serveur vpn.ldn-fai.net
    option gateway 'fe80::a3e:5dff:fe74:b40a' # adresse link-local de la route IPv6 par défaut de mon Turris

config route6
    option interface 'vpn'
    option target '::/0'
    option gateway 'fe80::a3e:5dff:fe74:b40a'
    # Oui, c'est la même qu'au dessus. On pourrait croire que ça ne fonctionne pas, mais si.
    # Et je ne vois pas trace d'une IP orange lors d'un traceroute6.
    # Donc vraiment, je ne sais pas si c'est nécessaire

Pour propo­ser de l’IPv6 en DHCP à votre réseau local, mettez ceci dans /etc/config/network :

config interface 'lan'
    option ifname 'eth0 eth2'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6prefix '2001:DB8:42::/48' # Range IPv6 fourni par LDN
    option ip6assign '64' # Je réduis à un /64 pour mon réseau local
    option ip6hint 'beef' # Je choisis 2001:DB8:42:beef::/64 pour mon réseau local

Pourquoi créer un bridge entre eth0 et eth2 ? Bon sang, je ne sais plus… mais ça fonc­tionne donc bon.

Bonus : si les hôtes de votre réseau local ne peuvent pas se connec­ter les uns aux autres, j’avais déjà écrit un article avec la solu­tion 🙂

Pour le Turris, j’ai fait ainsi, dans /etc/config/network, d’après ce post :

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6'
Me soutenir sur Tipeee Me soutenir sur Liberapay